Validating Geant4 versions 7.1 and 8.3 against 6.1 for BaBar